Gmelius Sharing is slow for some users
Incident Report for Gmelius Ltd
Resolved
This incident has been resolved.
Posted Mar 12, 2022 - 06:03 UTC
Monitoring
We received some reports mentioning that Gmelius sharing was slowed down.
The issue is now resolved, we are still monitoring the situation.
Posted Mar 12, 2022 - 05:14 UTC
This incident affected: Databases and API.