⚠️ Gmelius Extension Temporary Unavailability on Chrome Webstore
Incident Report for Gmelius
Resolved
The "Gmelius for Gmail" extension is now listed again on the Chrome Webstore.
It is now possible to download it from the Chrome Webstore.
Please note that during this incident, current users that already had the Chrome Extension have not been impacted.

We would like to thank you again for your understanding.
Posted Dec 04, 2024 - 11:06 CET
Identified
We regret to inform you that the "Gmelius for Gmail" extension has been wrongly taken down from the Chrome Webstore. Rest assured, we are in direct contact with Google to resolve this issue as quickly as possible.

Our team is committed to minimizing any disruption, and we will keep you updated on the status of this matter. Meanwhile, you can download a local copy of the extension by going to https://gmelius.com/download/extension?ref=status

Thank you for your understanding and patience. If you have any questions or need assistance, please don’t hesitate to reach out to our support team at support@gmelius.com.

Stay tuned here for updates.
Posted Dec 03, 2024 - 13:48 CET
This incident affected: Extension for Gmail.