Sharing slow
Incident Report for Gmelius Ltd
Resolved
This incident has been resolved
Posted May 04, 2022 - 18:09 UTC
Monitoring
The delay on the sharing has returned to normal.
We are still monitoring the issue.
Some emails received during the incident might still be synced in the coming minutes.
Posted May 04, 2022 - 17:29 UTC
Investigating
We are currently investigating an issue on our sharing.
Emails might be delayed during that time.
Posted May 04, 2022 - 17:06 UTC
This incident affected: API.